summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndreas Eversberg2010-03-11 14:07:20 +0100
committerAndreas Eversberg2010-03-11 14:07:20 +0100
commit0c65074b5b88b2da2390078d0fab6c72f228709d (patch)
tree297bc8a552f3dde8cdc96f8a2a40f6c8916444ed /Makefile.am
parentregister_fd() bugfix. (diff)
downloadlcr-0c65074b5b88b2da2390078d0fab6c72f228709d.tar.gz
lcr-0c65074b5b88b2da2390078d0fab6c72f228709d.tar.xz
lcr-0c65074b5b88b2da2390078d0fab6c72f228709d.zip
Fixed compiler warnings when compiling with gcc 4.3.4.
Fixed names of moved include files (OpenBSC). modified: Makefile.am modified: Makefile.in modified: README modified: chan_lcr.c modified: configure modified: configure.ac modified: genrc.c modified: gentones.c modified: genwave.c modified: gsm.cpp modified: mISDN.cpp modified: main.c modified: port.cpp modified: tones.c modified: trace.c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 17f9a29..2125468 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,11 +45,11 @@ INSTALLATION_DEFINES = \
if ENABLE_GSM
-GSM_INCLUDE = -DWITH_GSM -I./openbsc/include
+GSM_INCLUDE = -DWITH_GSM -I./openbsc/include -I./libosmocore/include
GSM_SOURCE = gsm_audio.c gsm.cpp gsm_conf.c openbsc/src/bsc_init.c openbsc/src/vty_interface.c openbsc/src/vty_interface_layer3.c
-GSM_LIB = /usr/lib/libgsm.a ./openbsc/src/libbsc.a ./openbsc/src/libmsc.a ./openbsc/src/libvty.a -ldbi -lcrypt
+GSM_LIB = /usr/lib/libgsm.a ./openbsc/src/libbsc.a ./openbsc/src/libmsc.a ./openbsc/src/libvty.a -L./libosmocore/src/ -losmocore -ldbi -lcrypt
#gsm_audio.po: gsm_audio.c gsm_audio.h
# $(CC) -D_GNU_SOURCE -fPIC -c gsm_audio.c -o gsm_audio.po