summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndreas Eversberg2010-05-31 08:44:30 +0200
committerAndreas Eversberg2010-05-31 08:44:30 +0200
commit0f805e041a900551a8c3cf9a75a78c2b34e1977c (patch)
tree78fb5ce15b7a669ae9a9faf214b6e7bd00c73ffa /Makefile.am
parentAdded patch to play ringing tone when connected but the call is forwarded (diff)
downloadlcr-0f805e041a900551a8c3cf9a75a78c2b34e1977c.tar.gz
lcr-0f805e041a900551a8c3cf9a75a78c2b34e1977c.tar.xz
lcr-0f805e041a900551a8c3cf9a75a78c2b34e1977c.zip
Fixed LCR to work with the current API of OpenBSC.
modified: Makefile.am modified: Makefile.in modified: README modified: gsm.cpp
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b56560b..aaa23f6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,11 +45,11 @@ INSTALLATION_DEFINES = \
if ENABLE_GSM
-GSM_INCLUDE = -DWITH_GSM -I./openbsc/include -I./libosmocore/include
+GSM_INCLUDE = -DWITH_GSM -I./openbsc/include -I./libosmocore/include -I./openbsc
-GSM_SOURCE = gsm_audio.c gsm.cpp gsm_conf.c openbsc/src/bsc_init.c openbsc/src/vty_interface.c openbsc/src/vty_interface_layer3.c
+GSM_SOURCE = gsm_audio.c gsm.cpp gsm_conf.c openbsc/src/bsc_init.c openbsc/src/bsc_vty.c openbsc/src/vty_interface_layer3.c openbsc/src/bsc_api.c openbsc/src/bsc_version.c
-GSM_LIB = /usr/lib/libgsm.a ./openbsc/src/libbsc.a ./openbsc/src/libmsc.a ./openbsc/src/libvty.a -L./libosmocore/src/ -losmocore -ldbi -lcrypt
+GSM_LIB = /usr/lib/libgsm.a ./openbsc/src/libbsc.a ./openbsc/src/libmsc.a ./openbsc/src/libvty.a -losmovty -losmocore -ldbi -lcrypt
#gsm_audio.po: gsm_audio.c gsm_audio.h
# $(CC) -D_GNU_SOURCE -fPIC -c gsm_audio.c -o gsm_audio.po