summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorroot2009-06-18 10:06:31 +0200
committerroot2009-06-18 10:06:31 +0200
commit4ec1520c572c4099b478897e4a6ee3a28622ca44 (patch)
treed722c4fab995b77c3c31b924846f07ce78435992 /Makefile.am
parentgsm improvements (diff)
downloadlcr-4ec1520c572c4099b478897e4a6ee3a28622ca44.tar.gz
lcr-4ec1520c572c4099b478897e4a6ee3a28622ca44.tar.xz
lcr-4ec1520c572c4099b478897e4a6ee3a28622ca44.zip
Added GSM IMSI dialing by using dialing "imsi-<number>".
Applied API change of OpenBSC. modified: Makefile.am modified: Makefile.in modified: README modified: bootstrap.c modified: default/gsm.conf modified: dss1.cpp modified: gsm.cpp modified: gsm_audio.c modified: gsm_conf.c modified: interface.c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 61d8a86..c072870 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,7 +49,7 @@ GSM_INCLUDE = -DWITH_GSM
GSM_SOURCE = gsm_audio.c gsm.cpp gsm_conf.c bootstrap.c
-GSM_LIB = /usr/local/lib/libgsm.a /usr/local/lib/libbsc.a /usr/local/lib/libvty.a -ldbi -lcrypt
+GSM_LIB = /usr/lib/libgsm.a /usr/local/lib/libbsc.a /usr/local/lib/libvty.a -ldbi -lcrypt
#gsm_audio.po: gsm_audio.c gsm_audio.h
# $(CC) -D_GNU_SOURCE -fPIC -c gsm_audio.c -o gsm_audio.po
@@ -124,9 +124,11 @@ install-data-hook:
@if test -a $(CONFIGdir)/routing.conf ; then \
echo "NOTE: routing.conf already exists, not changed." ; else \
cp -v default/routing.conf $(CONFIGdir) ; fi
+if ENABLE_GSM
@if test -a $(CONFIGdir)/gsm.conf ; then \
echo "NOTE: gsm.conf already exists, not changed." ; else \
cp -v default/gsm.conf $(CONFIGdir) ; fi
+endif
@if test -a $(CONFIGdir)/numbering_int.conf ; then \
echo "NOTE: numbering_int.conf is obsolete, please use routing." ; fi
@if test -a $(CONFIGdir)/numbering_ext.conf ; then \