summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndreas Eversberg2008-10-11 08:51:38 +0200
committerAndreas Eversberg2008-10-11 08:51:38 +0200
commit8033d9a61ad5d5dfb745495a1c7808df650595f9 (patch)
tree4d90c8f3b85dc3df3ce5e1ad788add5cb4ada6b1 /Makefile.am
parentchan_lcr: fixed some "bridging typos" (diff)
downloadlcr-8033d9a61ad5d5dfb745495a1c7808df650595f9.tar.gz
lcr-8033d9a61ad5d5dfb745495a1c7808df650595f9.tar.xz
lcr-8033d9a61ad5d5dfb745495a1c7808df650595f9.zip
now chan_lcr.so is moved to asterisk' modules directory when installing.
modified: Makefile.am modified: Makefile.in modified: autogen.sh
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 762c1b3..8eebb53 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,6 +28,8 @@
INSTALLdir = /usr/local/lcr
+astmoddir = /usr/lib/asterisk/modules
+
INSTALLATION_DEFINES = \
-DCONFIG_DATA="\"$(INSTALLdir)\"" \
-DSHARE_DATA="\"$(INSTALLdir)\"" \
@@ -112,6 +114,10 @@ install-data-hook:
@if test -a $(INSTALLdir)/tones_efi ; then \
echo "NOTE: special efi tones already exists, not overwritten." ; else \
cp -a tones_efi $(INSTALLdir) ; fi
+if ENABLE_ASTERISK_CHANNEL_DRIVER
+ @echo "Moving chan_lcr.so (if it fails, do it manually)"
+ mv $(sbindir)/chan_lcr.so $(astmoddir)
+endif
# test rule, nothing important
#echo: