summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJörg Habenicht2007-10-03 18:25:20 +0200
committerJörg Habenicht2007-10-03 18:25:20 +0200
commitba93d3abf0686af2d363e3dd9f58da86ee22dfdb (patch)
tree85802f995e04800cfbba191320762e310904226c /Makefile.am
parentremoved: --with-crypto (diff)
downloadlcr-ba93d3abf0686af2d363e3dd9f58da86ee22dfdb.tar.gz
lcr-ba93d3abf0686af2d363e3dd9f58da86ee22dfdb.tar.xz
lcr-ba93d3abf0686af2d363e3dd9f58da86ee22dfdb.zip
removed: old PBX definition
added: rpath option to link against development lib in non standard dirs
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 14 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index e5b97b2..84037b1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,12 @@
## Makefile.am -- Process this file with automake to produce Makefile.in
-INSTALLATION_DEFINES = -DCONFIG_DATA="\"$(pkgsysconfdir)\"" -DSHARE_DATA="\"$(pkgdatadir)\"" -DLOG_DIR="\"$(pkglogdir)\"" -DPBX -DINSTALL_DATA="\"$(pkgdatadir)\""
+INSTALLATION_DEFINES = \
+ -DCONFIG_DATA="\"$(pkgsysconfdir)\"" \
+ -DSHARE_DATA="\"$(pkgdatadir)\"" \
+ -DLOG_DIR="\"$(pkglogdir)\"" \
+ -DINSTALL_DATA="\"$(pkgdatadir)\""
+
# FIXME: find a macro for the include path of linux
# or is /lib/modules/$(uname -r)/source/include sufficient?
# Do we take /usr/src/linux or /usr/src/linux-$(uname -r)
@@ -10,6 +15,11 @@ INSTALLATION_DEFINES = -DCONFIG_DATA="\"$(pkgsysconfdir)\"" -DSHARE_DATA="\"$(pk
INCLUDES = $(all_includes) $(INSTALLATION_DEFINES)
+# add nonstandard lib installation paths to this
+MISDN_LIB_INSTALL_PATH=$(misdnuser_libraries)
+AM_LDFLAGS = -Wl,-rpath,$(MISDN_LIB_INSTALL_PATH)
+
+
bin_PROGRAMS = lcradmin gentones genwave #lcrwatch
sbin_PROGRAMS = lcr genrc genextension
@@ -109,13 +119,13 @@ LINK=$(CXXLINK)
pkglogdir=$(localstatedir)/log/@PACKAGE@
-# install runtime config in $prefix/etc/pbx4linux/ (e.g. /etc/pbx4linux)
-# and voice data in $prefix/share/pbx4linux/ (e.g. /usr/share/pbx4linux)
+# install runtime config in $prefix/etc/lcr/ (e.g. /etc/lcr)
+# and voice data in $prefix/share/lcr/ (e.g. /usr/share/lcr)
pkgsysconfdir=$(sysconfdir)/@PACKAGE@
dist_pkgsysconf_DATA = $(config_default)
# install all voice data files along with their directory structure
-# into $prefix/share/pbx4linux
+# into $prefix/share/lcr
nobase_dist_pkgdata_DATA = $(vbox_english) $(vbox_german) \
$(tones_american) $(tones_efi) $(tones_german)