summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorroot2009-08-23 14:58:21 +0200
committerroot2009-08-23 14:58:21 +0200
commitcf1ea15cc320019d7b41eb56aeeb3c1956fbb7a0 (patch)
treed24ffc03e9e15fe0d012f1a063ee0b1a83493f64 /Makefile.am
parentMinor fix in display facility. (diff)
downloadlcr-cf1ea15cc320019d7b41eb56aeeb3c1956fbb7a0.tar.gz
lcr-cf1ea15cc320019d7b41eb56aeeb3c1956fbb7a0.tar.xz
lcr-cf1ea15cc320019d7b41eb56aeeb3c1956fbb7a0.zip
LCR now compiles with current version of OpenBSC.
No more patch is required, just link openbsc directory to LCR source directory and run "configure": cd lcr ln -s path_to_openbsc/openbsc . modified: Makefile.am modified: Makefile.in deleted: bootstrap.c deleted: bootstrap.h modified: configure modified: configure.ac modified: default/gsm.conf modified: gsm.cpp modified: gsm.h modified: gsm_conf.c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index c072870..84bfd89 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,11 +45,11 @@ INSTALLATION_DEFINES = \
if ENABLE_GSM
-GSM_INCLUDE = -DWITH_GSM
+GSM_INCLUDE = -DWITH_GSM -I./openbsc/include
-GSM_SOURCE = gsm_audio.c gsm.cpp gsm_conf.c bootstrap.c
+GSM_SOURCE = gsm_audio.c gsm.cpp gsm_conf.c openbsc/src/bsc_init.c openbsc/src/vty_interface.c openbsc/src/vty_interface_layer3.c
-GSM_LIB = /usr/lib/libgsm.a /usr/local/lib/libbsc.a /usr/local/lib/libvty.a -ldbi -lcrypt
+GSM_LIB = /usr/lib/libgsm.a ./openbsc/src/libbsc.a ./openbsc/src/libmsc.a ./openbsc/src/libvty.a -ldbi -lcrypt
#gsm_audio.po: gsm_audio.c gsm_audio.h
# $(CC) -D_GNU_SOURCE -fPIC -c gsm_audio.c -o gsm_audio.po
@@ -128,6 +128,9 @@ if ENABLE_GSM
@if test -a $(CONFIGdir)/gsm.conf ; then \
echo "NOTE: gsm.conf already exists, not changed." ; else \
cp -v default/gsm.conf $(CONFIGdir) ; fi
+ @if test -a $(CONFIGdir)/openbsc.cfg ; then \
+ echo "NOTE: openbsc.cfg already exists, not changed." ; else \
+ cp -v default/openbsc.cfg $(CONFIGdir) ; fi
endif
@if test -a $(CONFIGdir)/numbering_int.conf ; then \
echo "NOTE: numbering_int.conf is obsolete, please use routing." ; fi