summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Eversberg2010-12-14 10:56:09 +0100
committerAndreas Eversberg2010-12-14 10:56:09 +0100
commit5705b3e17b395a6ad08a689cfe212bca20427bd5 (patch)
tree2c447dcbe9cde68d96f983e15d40cad356c2f100 /configure.ac
parentRemoved change history from 'README' file. (diff)
downloadlcr-5705b3e17b395a6ad08a689cfe212bca20427bd5.tar.gz
lcr-5705b3e17b395a6ad08a689cfe212bca20427bd5.tar.xz
lcr-5705b3e17b395a6ad08a689cfe212bca20427bd5.zip
Improved and applied Wimpy's Asterisk 1.8.x support.
configure script will automatically detect new asterisk API, so there is no need for different chan_lcr.c source codes. 'type', 'presentation', and 'screening indicator' are now transcoded.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 81eb404..4b14e8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,6 +71,7 @@ AS_IF([test "x$with_asterisk" != xno],
if test "x$with_asterisk" = "xyes"; then
ast_tone_zone_sound=
+ ast_1_8_or_higher=
AC_MSG_CHECKING([for struct tone_zone_sound in asterisk/indications.h])
tzs_test_result=no
@@ -108,7 +109,22 @@ if test "x$with_asterisk" = "xyes"; then
AC_MSG_FAILURE([No ast_tone_zone_sound, confused...])
fi
- AST_CFLAGS="-Dtone_zone_sound=$ast_tone_zone_sound"
+ AC_MSG_CHECKING([for struct ast_party_caller in asterisk/channel.h])
+ apc_test_result=no
+ AC_COMPILE_IFELSE([
+ AC_LANG_PROGRAM(
+ [[#include <asterisk.h>],
+ [#include <asterisk/channel.h>]],
+ [[struct ast_party_caller * caller = NULL; (void) caller->id;]])],
+ [apc_test_result=yes])
+ AC_MSG_RESULT([$apc_test_result])
+
+ if test "x$apc_test_result" = "xyes"; then
+ ast_1_8_or_higher="-DAST_1_8_OR_HIGHER"
+ fi
+
+ AST_CFLAGS="-Dtone_zone_sound=$ast_tone_zone_sound $ast_1_8_or_higher"
+
AC_SUBST([AST_CFLAGS])
fi