summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Eversberg2010-05-31 18:45:02 +0200
committerAndreas Eversberg2010-05-31 18:45:02 +0200
commita12d7eee22a72f4c999535892763dde15212e89e (patch)
tree32e20ad128c8bba3c80441ca771da8aa0c4fd5f2 /configure.ac
parentFixed LCR to work with the current API of OpenBSC. (diff)
downloadlcr-a12d7eee22a72f4c999535892763dde15212e89e.tar.gz
lcr-a12d7eee22a72f4c999535892763dde15212e89e.tar.xz
lcr-a12d7eee22a72f4c999535892763dde15212e89e.zip
Splitted GSM support into BS (network) and MS (mobile) part.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 31 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index cc7cc9b..f02cec8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,25 +95,47 @@ AS_IF([test "x$with_ssl" != xno],
]
)
-# check for gsm
-AC_ARG_WITH([gsm],
- [AS_HELP_STRING([--with-gsm],
+# check for gsm-bs
+AC_ARG_WITH([gsm-bs],
+ [AS_HELP_STRING([--with-gsm-bs],
[compile with OpenBSC support @<:@default=check@:>@])
],
[],
- [with_gsm="check"])
+ [with_gsm_bs="check"])
-AS_IF([test "x$with_gsm" != xno],
+AS_IF([test "x$with_gsm_bs" != xno],
[AC_CHECK_FILE([openbsc/include/openbsc/gsm_data.h],
- [with_gsm="yes"],
- [if test "x$with_gsm" != xcheck ; then
+ [with_gsm_bs="yes"],
+ [if test "x$with_gsm_bs" != xcheck ; then
AC_MSG_FAILURE(
- [--with-gsm was given, but openbsc/include/openbsc/gsm_data.h was not found! Pleas link OpenBSC and libosmocore source directory to LCR source directory: ln -s path_to_openbsc/openbsc/ openbsc ; ln -s patch_to_libosmocore osmocore])
+ [--with-gsm-bs was given, but openbsc/include/openbsc/gsm_data.h was not found! Pleas link OpenBSC and libosmocore source directory to LCR source directory: ln -s path_to_openbsc/openbsc/ openbsc ; ln -s patch_to_libosmocore libosmocore])
fi
])
])
-AM_CONDITIONAL(ENABLE_GSM, test "x$with_gsm" == "xyes" )
+AM_CONDITIONAL(ENABLE_GSM_BS, test "x$with_gsm_bs" == "xyes" )
+
+# check for gsm-ms
+AC_ARG_WITH([gsm-ms],
+ [AS_HELP_STRING([--with-gsm-ms],
+ [compile with Osmocom-bb support @<:@default=check@:>@])
+ ],
+ [],
+ [with_gsm_ms="check"])
+
+AS_IF([test "x$with_gsm_ms" != xno],
+ [AC_CHECK_FILE([layer23/include/osmocom/osmocom_data.h],
+ [with_gsm_ms="yes"],
+ [if test "x$with_gsm_ms" != xcheck ; then
+ AC_MSG_FAILURE(
+ [--with-gsm-ms was given, but osmocom-bb/include/osmocom/osmocom_data.h was not found! Pleas link Osmocom-BB and libosmocore source directory to LCR source directory: ln -s path_to_osmocom-bb/src/host/layer23/ layer23 ; ln -s path_to_libosmocore libosmocore])
+ fi
+ ])
+ ])
+
+AM_CONDITIONAL(ENABLE_GSM_MS, test "x$with_gsm_ms" == "xyes" )
+
+AM_CONDITIONAL(ENABLE_GSM, test "x$with_gsm_bs" == "xyes" -o "x$with_gsm_ms" == "xyes")
# check for ss5
AC_ARG_WITH([ss5],