summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Eversberg2010-10-30 17:21:54 +0200
committerAndreas Eversberg2010-10-30 17:24:30 +0200
commitb19fbde00049c796e15d8efb807c24cd576aad8e (patch)
tree6a31a309fd93dd22bb0981d9a0030fdb35bac916 /configure.ac
parent[chan_lcr] Fixed caller ID by clearing ast->cid first (diff)
downloadlcr-b19fbde00049c796e15d8efb807c24cd576aad8e.tar.gz
lcr-b19fbde00049c796e15d8efb807c24cd576aad8e.tar.xz
lcr-b19fbde00049c796e15d8efb807c24cd576aad8e.zip
Make LCR compile with the latest OpenBSC master branch
modified: Makefile.in modified: aclocal.m4 modified: config.h.in modified: configure modified: configure.ac modified: gsm_bs.cpp
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f0c60c2..e2910c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,7 @@
dnl This file is part of linux-call-router
dnl Copyright (C) 2007 Joerg Habenicht (j.habenicht@gmx.de)
dnl Copyright (C) 2008 Peter Schlaile (peter -at- schlaile.de)
+dnl Copyright (C) 2010 Andreas Eversberg (jolly@eversberg.eu)
dnl This program is free software; you can redistribute it and/or
dnl modify it under the terms of the GNU General Public License as
@@ -148,11 +149,13 @@ AC_ARG_WITH([gsm-bs],
AS_IF([test "x$with_gsm_bs" != xno],
[AC_MSG_CHECKING(openbsc/include/openbsc/gsm_data.h)
- if test -d openbsc/include/openbsc/gsm_data.h; then
+ if test -e openbsc/include/openbsc/gsm_data.h; then
with_gsm_bs="yes"
AC_MSG_RESULT(yes)
elif test "x$with_gsm_bs" != xcheck ; then
AC_MSG_FAILURE([--with-gsm-bs was given, but openbsc/include/openbsc/gsm_data.h was not found! Please link OpenBSC and libosmocore source directory to LCR source directory: ln -s path_to_openbsc/openbsc/ openbsc ; ln -s patch_to_libosmocore libosmocore])
+ else
+ AC_MSG_RESULT(no)
fi
])
@@ -168,11 +171,13 @@ AC_ARG_WITH([gsm-ms],
AS_IF([test "x$with_gsm_ms" != xno],
[AC_MSG_CHECKING(layer23/include/osmocom/osmocom_data.h)
- if test -d layer23/include/osmocom/osmocom_data.h; then
+ if test -e layer23/include/osmocom/osmocom_data.h; then
with_gsm_ms="yes"
AC_MSG_RESULT(yes)
- elif test "x$with_gsm_bs" != xcheck ; then
+ elif test "x$with_gsm_ms" != xcheck ; then
AC_MSG_FAILURE([--with-gsm-ms was given, but layer23/include/osmocom/osmocom_data.h was not found! Please link Osmocom-BB and libosmocore source directory to LCR source directory: ln -s path_to_osmocom-bb/src/host/layer23/ layer23 ; ln -s path_to_libosmocore libosmocore])
+ else
+ AC_MSG_RESULT(no)
fi
])