summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorroot2009-08-23 14:58:21 +0200
committerroot2009-08-23 14:58:21 +0200
commitcf1ea15cc320019d7b41eb56aeeb3c1956fbb7a0 (patch)
treed24ffc03e9e15fe0d012f1a063ee0b1a83493f64 /configure.ac
parentMinor fix in display facility. (diff)
downloadlcr-cf1ea15cc320019d7b41eb56aeeb3c1956fbb7a0.tar.gz
lcr-cf1ea15cc320019d7b41eb56aeeb3c1956fbb7a0.tar.xz
lcr-cf1ea15cc320019d7b41eb56aeeb3c1956fbb7a0.zip
LCR now compiles with current version of OpenBSC.
No more patch is required, just link openbsc directory to LCR source directory and run "configure": cd lcr ln -s path_to_openbsc/openbsc . modified: Makefile.am modified: Makefile.in deleted: bootstrap.c deleted: bootstrap.h modified: configure modified: configure.ac modified: default/gsm.conf modified: gsm.cpp modified: gsm.h modified: gsm_conf.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index bbd770f..c4850b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,12 +98,22 @@ AS_IF([test "x$with_ssl" != xno],
# check for gsm
AC_ARG_WITH([gsm],
[AS_HELP_STRING([--with-gsm],
- [compile with OpenBSC support (libbsc) @<:@default=no@:>@])
+ [compile with OpenBSC support @<:@default=no@:>@])
],
[],
- [with_gsm=no])
+ [with_gsm="check"])
+
+AS_IF([test "x$with_gsm" != xno],
+ [AC_CHECK_FILE([openbsc/include/openbsc/gsm_data.h],
+ [with_gsm="yes"],
+ [if test "x$with_gsm" != xcheck ; then
+ AC_MSG_FAILURE(
+ [--with-gsm was given, but openbsc/include/openbsc/gsm_data.h was not found! Pleas link OpenBSC source directory to LCR source directory: ln -s path_to_openbsc/openbsc/ .])
+ fi
+ ])
+ ])
-AM_CONDITIONAL(ENABLE_GSM, test "x$with_gsm" != "xno" )
+AM_CONDITIONAL(ENABLE_GSM, test "x$with_gsm" == "xyes" )
# Checks for libraries.
AC_CHECK_LIB([m], [main])