summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Eversberg2010-07-25 17:40:34 +0200
committerAndreas Eversberg2010-07-25 17:41:24 +0200
commitfc6a1a6e99c90e47a998d56f852c7db29f44dc35 (patch)
treeb9b875a6bb75bb735fe07758374f09c402bb0828 /configure.ac
parentFixed API and incomming calls from Osmocom-BB. (diff)
downloadlcr-fc6a1a6e99c90e47a998d56f852c7db29f44dc35.tar.gz
lcr-fc6a1a6e99c90e47a998d56f852c7db29f44dc35.tar.xz
lcr-fc6a1a6e99c90e47a998d56f852c7db29f44dc35.zip
Hi all,
as described in http://www.gnu.org/software/hello/manual/autoconf/Files.html, AC_CHECK_FILE breaks when cross configuring/compiling LCR. Attached patch replaces AC_CHECK_FILE by 'test -d' and some extra code in configure.ac. Cheers Arny
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 7bd5d87..f0c60c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -147,13 +147,13 @@ AC_ARG_WITH([gsm-bs],
[with_gsm_bs="check"])
AS_IF([test "x$with_gsm_bs" != xno],
- [AC_CHECK_FILE([openbsc/include/openbsc/gsm_data.h],
- [with_gsm_bs="yes"],
- [if test "x$with_gsm_bs" != xcheck ; then
- AC_MSG_FAILURE(
- [--with-gsm-bs was given, but openbsc/include/openbsc/gsm_data.h was not found! Pleas link OpenBSC and libosmocore source directory to LCR source directory: ln -s path_to_openbsc/openbsc/ openbsc ; ln -s patch_to_libosmocore libosmocore])
- fi
- ])
+ [AC_MSG_CHECKING(openbsc/include/openbsc/gsm_data.h)
+ if test -d openbsc/include/openbsc/gsm_data.h; then
+ with_gsm_bs="yes"
+ AC_MSG_RESULT(yes)
+ elif test "x$with_gsm_bs" != xcheck ; then
+ AC_MSG_FAILURE([--with-gsm-bs was given, but openbsc/include/openbsc/gsm_data.h was not found! Please link OpenBSC and libosmocore source directory to LCR source directory: ln -s path_to_openbsc/openbsc/ openbsc ; ln -s patch_to_libosmocore libosmocore])
+ fi
])
AM_CONDITIONAL(ENABLE_GSM_BS, test "x$with_gsm_bs" == "xyes" )
@@ -167,13 +167,13 @@ AC_ARG_WITH([gsm-ms],
[with_gsm_ms="check"])
AS_IF([test "x$with_gsm_ms" != xno],
- [AC_CHECK_FILE([layer23/include/osmocom/osmocom_data.h],
- [with_gsm_ms="yes"],
- [if test "x$with_gsm_ms" != xcheck ; then
- AC_MSG_FAILURE(
- [--with-gsm-ms was given, but osmocom-bb/include/osmocom/osmocom_data.h was not found! Pleas link Osmocom-BB and libosmocore source directory to LCR source directory: ln -s path_to_osmocom-bb/src/host/layer23/ layer23 ; ln -s path_to_libosmocore libosmocore])
- fi
- ])
+ [AC_MSG_CHECKING(layer23/include/osmocom/osmocom_data.h)
+ if test -d layer23/include/osmocom/osmocom_data.h; then
+ with_gsm_ms="yes"
+ AC_MSG_RESULT(yes)
+ elif test "x$with_gsm_bs" != xcheck ; then
+ AC_MSG_FAILURE([--with-gsm-ms was given, but layer23/include/osmocom/osmocom_data.h was not found! Please link Osmocom-BB and libosmocore source directory to LCR source directory: ln -s path_to_osmocom-bb/src/host/layer23/ layer23 ; ln -s path_to_libosmocore libosmocore])
+ fi
])
AM_CONDITIONAL(ENABLE_GSM_MS, test "x$with_gsm_ms" == "xyes" )