summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index bce48d1..b56560b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,11 +45,11 @@ INSTALLATION_DEFINES = \
if ENABLE_GSM
-GSM_INCLUDE = -DWITH_GSM -I./openbsc/include
+GSM_INCLUDE = -DWITH_GSM -I./openbsc/include -I./libosmocore/include
GSM_SOURCE = gsm_audio.c gsm.cpp gsm_conf.c openbsc/src/bsc_init.c openbsc/src/vty_interface.c openbsc/src/vty_interface_layer3.c
-GSM_LIB = /usr/lib/libgsm.a ./openbsc/src/libbsc.a ./openbsc/src/libmsc.a ./openbsc/src/libvty.a -ldbi -lcrypt
+GSM_LIB = /usr/lib/libgsm.a ./openbsc/src/libbsc.a ./openbsc/src/libmsc.a ./openbsc/src/libvty.a -L./libosmocore/src/ -losmocore -ldbi -lcrypt
#gsm_audio.po: gsm_audio.c gsm_audio.h
# $(CC) -D_GNU_SOURCE -fPIC -c gsm_audio.c -o gsm_audio.po
@@ -72,7 +72,7 @@ if ENABLE_ASTERISK_CHANNEL_DRIVER
noinst_PROGRAMS = chan_lcr.so
chan_lcr_so_SOURCES =
chan_lcr_so_LDFLAGS = -shared
-chan_lcr_so_LDADD = chan_lcr.po bchannel.po options.po callerid.po
+chan_lcr_so_LDADD = chan_lcr.po bchannel.po options.po callerid.po select.po
chan_lcr.po: chan_lcr.c chan_lcr.h
$(CC) $(INCLUDES) -D_GNU_SOURCE -fPIC -c chan_lcr.c -o chan_lcr.po
@@ -86,15 +86,18 @@ callerid.po: callerid.c callerid.h
options.po: options.c options.h
$(CC) $(INCLUDES) -D_GNU_SOURCE -fPIC -c options.c -o options.po
+select.po: select.c select.h
+ $(CC) $(INCLUDES) -D_GNU_SOURCE -fPIC -c select.c -o select.po
+
install-exec-hook:
mkdir -p $(astmoddir)
$(INSTALL) -d $(astmoddir)
$(INSTALL) chan_lcr.so $(astmoddir)
endif
-INCLUDES = $(all_includes) $(GSM_INCLUDE) $(SS5_INCLUDE) -Wall -I/usr/include/mISDNuser $(INSTALLATION_DEFINES)
+INCLUDES = $(all_includes) $(GSM_INCLUDE) $(SS5_INCLUDE) -Wall $(INSTALLATION_DEFINES)
-lcr_SOURCES = $(GSM_SOURCE) $(SS5_SOURCE) action.cpp mISDN.cpp tones.c \
+lcr_SOURCES = $(GSM_SOURCE) $(SS5_SOURCE) select.c action.cpp mISDN.cpp tones.c \
action_efi.cpp crypt.cpp mail.c trace.c \
action_vbox.cpp dss1.cpp main.c \
vbox.cpp alawulaw.c endpoint.cpp interface.c message.c \