summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso2011-06-05 18:32:44 +0200
committerPablo Neira Ayuso2011-06-05 18:32:44 +0200
commit0ba77d53a97906ee70a262083fb30f67fe8801c5 (patch)
tree8065c7c43c339458e9ef6425a2d45f3bedf777ad /Makefile.am
downloadlibosmo-abis-0ba77d53a97906ee70a262083fb30f67fe8801c5.tar.gz
libosmo-abis-0ba77d53a97906ee70a262083fb30f67fe8801c5.tar.xz
libosmo-abis-0ba77d53a97906ee70a262083fb30f67fe8801c5.zip
initial commit of libosmo-abis
still many things to get fixed
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..17b9dbd
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,14 @@
+AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
+ACLOCAL_AMFLAGS = -I m4
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+SUBDIRS = include src tests
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libosmoabis.pc
+
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version