summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso2011-07-08 16:21:55 +0200
committerPablo Neira Ayuso2011-07-08 16:21:55 +0200
commit88136fc6dd4c432e13193c9e29c4bea927141812 (patch)
tree4bb8372b765223af9cd89e436a5d167a1fdd3c16 /tests/Makefile.am
parenttests: close OML and RSL if set for the BSC example (diff)
downloadlibosmo-abis-88136fc6dd4c432e13193c9e29c4bea927141812.tar.gz
libosmo-abis-88136fc6dd4c432e13193c9e29c4bea927141812.tar.xz
libosmo-abis-88136fc6dd4c432e13193c9e29c4bea927141812.zip
hsl: BTS support
This patch adds the BTS support for the hsl driver. It includes two examples under the tests/ directory.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5cb6447..26500a1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,6 +4,8 @@ AM_LDFLAGS = $(COVERAGE_LDFLAGS)
noinst_PROGRAMS = e1inp_ipa_bsc_test \
e1inp_ipa_bts_test \
+ e1inp_hsl_bsc_test \
+ e1inp_hsl_bts_test \
ipa_proxy_test
e1inp_ipa_bsc_test_SOURCES = e1inp_ipa_bsc_test.c
@@ -14,6 +16,14 @@ e1inp_ipa_bts_test_SOURCES = e1inp_ipa_bts_test.c
e1inp_ipa_bts_test_LDADD = $(top_builddir)/src/libosmoabis.la \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
+e1inp_hsl_bsc_test_SOURCES = e1inp_hsl_bsc_test.c
+e1inp_hsl_bsc_test_LDADD = $(top_builddir)/src/libosmoabis.la \
+ $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
+
+e1inp_hsl_bts_test_SOURCES = e1inp_hsl_bts_test.c
+e1inp_hsl_bts_test_LDADD = $(top_builddir)/src/libosmoabis.la \
+ $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
+
ipa_proxy_test_SOURCES = ipa_proxy_test.c
ipa_proxy_test_LDADD = $(top_builddir)/src/libosmoabis.la \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)