summaryrefslogtreecommitdiffstats
path: root/src/trau/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/trau/Makefile.am')
-rw-r--r--src/trau/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/trau/Makefile.am b/src/trau/Makefile.am
new file mode 100644
index 0000000..47b5875
--- /dev/null
+++ b/src/trau/Makefile.am
@@ -0,0 +1,15 @@
+# This is _NOT_ the library release version, it's an API version.
+# Please read Chapter 6 "Library interface versions" of the libtool
+# documentation before making any modification
+LIBVERSION=0:0:0
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS= -fPIC -Wall \
+ $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOVTY_CFLAGS) \
+ $(ORTP_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) \
+ $(ORTP_LIBS) $(COVERAGE_LDFLAGS)
+
+lib_LTLIBRARIES = libosmotrau.la
+
+libosmotrau_la_SOURCES = osmo_ortp.c