summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlexander Huemer2011-05-24 15:16:13 +0200
committerHarald Welte2011-05-24 17:19:35 +0200
commit3d79f53284a300f15b4fc8356266dc23ae4ddce3 (patch)
tree7b7bb030428ba920bfd25e397d7441c139bff8b9 /configure.in
parentImport sytem information related definitions + code from openbsc (diff)
downloadlibosmocore-3d79f53284a300f15b4fc8356266dc23ae4ddce3.tar.gz
libosmocore-3d79f53284a300f15b4fc8356266dc23ae4ddce3.tar.xz
libosmocore-3d79f53284a300f15b4fc8356266dc23ae4ddce3.zip
libosmocore: add missing AC_LANG_SOURCE for current autoconf
autoconf >=2.68 demands the body of an AC_COMPILE_IFELSE to be wrapped in an AC_LANG_SOURCE macro, otherwise outputs annoying warnings on the invocation of `autoreconf -i`. this patch follows that demand.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2e22bb2..b923a21 100644
--- a/configure.in
+++ b/configure.in
@@ -24,7 +24,7 @@ AC_CHECK_HEADERS(execinfo.h sys/select.h sys/socket.h syslog.h ctype.h)
saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -fvisibility=hidden "
AC_MSG_CHECKING([if ${CC} supports -fvisibility=hidden])
-AC_COMPILE_IFELSE([char foo;],
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([char foo;])],
[ AC_MSG_RESULT([yes])
SYMBOL_VISIBILITY="-fvisibility=hidden"],
AC_MSG_RESULT([no]))