summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSylvain Munaut2010-07-25 18:08:54 +0200
committerSylvain Munaut2010-07-25 18:08:54 +0200
commitac3e61a7a6b8f56b74d4ebd9c0fcb9c5935294b1 (patch)
tree894fd9150a39bb1442467bdb1867b07d2b475cfe /configure.in
parentbuild: Use AS_HELP_STRING macro to format the ./configure --help better (diff)
downloadlibosmocore-ac3e61a7a6b8f56b74d4ebd9c0fcb9c5935294b1.tar.gz
libosmocore-ac3e61a7a6b8f56b74d4ebd9c0fcb9c5935294b1.tar.xz
libosmocore-ac3e61a7a6b8f56b74d4ebd9c0fcb9c5935294b1.zip
core: Add some generic panic handling
This also includes an option for a minimal 'infinite loop' type panic that could be required for embedded target that don't have abort() or fprintf() Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 140fdc2..c3e0061 100644
--- a/configure.in
+++ b/configure.in
@@ -66,6 +66,17 @@ AC_ARG_ENABLE(vty,
[enable_vty=0], [enable_vty=1])
AM_CONDITIONAL(ENABLE_VTY, test "x$enable_vty" = "x1")
+AC_ARG_ENABLE(panic_infloop,
+ [AS_HELP_STRING(
+ [--enable-panic-infloop],
+ [Trigger infinite loop on panic rather than fprintf/abort]
+ )],
+ [panic_infloop=1], [panic_infloop=0])
+if test "x$panic_infloop" = "x1"
+then
+ AC_DEFINE([PANIC_INFLOOP],[1],[Use infinite loop on panic rather than fprintf/abort])
+fi
+
AC_OUTPUT(
libosmocore.pc