summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther2010-10-06 18:00:15 +0200
committerHolger Hans Peter Freyther2010-10-08 13:23:18 +0200
commitc87f26652258ea7133efe57d1e8c8fc2f21c0efd (patch)
tree3fa26598e44cb2ac084ede967ec9c8c7ee8bfe2e /configure.in
parentgsm0480: Add USSD format functions to libosmocore (diff)
downloadlibosmocore-c87f26652258ea7133efe57d1e8c8fc2f21c0efd.tar.gz
libosmocore-c87f26652258ea7133efe57d1e8c8fc2f21c0efd.tar.xz
libosmocore-c87f26652258ea7133efe57d1e8c8fc2f21c0efd.zip
msgfile: Add a file parser for a simple file format
This file format will be used to store per country code, per network code messages. This will be used for various things ranging from access control, to messages...
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1684aaa..4c827b0 100644
--- a/configure.in
+++ b/configure.in
@@ -88,6 +88,14 @@ then
AC_DEFINE([BSC_FD_CHECK],[1],[Instrument the bsc_register_fd])
fi
+AC_ARG_ENABLE(msgfile,
+ [AS_HELP_STRING(
+ [--disable-msgfile],
+ [Disable support for the msgfile],
+ )],
+ [enable_msgfile=0], [enable_msgfile=1])
+AM_CONDITIONAL(ENABLE_MSGFILE, test "x$enable_msgfile" = "x1")
+
AC_OUTPUT(
libosmocore.pc
@@ -103,4 +111,5 @@ AC_OUTPUT(
tests/Makefile
tests/timer/Makefile
tests/sms/Makefile
+ tests/msgfile/Makefile
Makefile)