summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHarald Welte2010-03-07 20:33:59 +0100
committerHarald Welte2010-03-07 20:33:59 +0100
commitf8b2ba7dc850396c5910e8c76875e75d37479d34 (patch)
tree524650c90f9c0f83127dba870c7198595f57532d /configure.in
parentadd --disable-talloc option to build without talloc support (diff)
downloadlibosmocore-f8b2ba7dc850396c5910e8c76875e75d37479d34.tar.gz
libosmocore-f8b2ba7dc850396c5910e8c76875e75d37479d34.tar.xz
libosmocore-f8b2ba7dc850396c5910e8c76875e75d37479d34.zip
add option --disable-tests to disable building of test binaries
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1154196..abf7bf4 100644
--- a/configure.in
+++ b/configure.in
@@ -31,11 +31,15 @@ dnl Generate the output
AM_CONFIG_HEADER(config.h)
AC_ARG_ENABLE(talloc,
- [ --disable-talloc Support message buffer ],
+ [ --disable-talloc Disable building talloc memory allocator ],
[enable_talloc=0], [enable_talloc=1])
-
AM_CONDITIONAL(ENABLE_TALLOC, test "x$enable_talloc" = "x1")
+AC_ARG_ENABLE(tests,
+ [ --disable-tests Disable building test programs ],
+ [enable_tests=0], [enable_tests=1])
+AM_CONDITIONAL(ENABLE_TESTS, test "x$enable_tests" = "x1")
+
AC_OUTPUT(
libosmocore.pc
include/osmocore/Makefile