summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHarald Welte2010-08-24 15:17:13 +0200
committerHarald Welte2010-08-24 15:17:13 +0200
commitd4bb7ab66b6f31b2dc5a54b61aa294188e7fc74f (patch)
tree2e91bfbcf68deb74e4ea8ad8ddb4445374beb23f /debian/rules
parentbsc_fd: Add a build option to be able to debug fd list corruption (diff)
downloadlibosmocore-d4bb7ab66b6f31b2dc5a54b61aa294188e7fc74f.tar.gz
libosmocore-d4bb7ab66b6f31b2dc5a54b61aa294188e7fc74f.tar.xz
libosmocore-d4bb7ab66b6f31b2dc5a54b61aa294188e7fc74f.zip
add debian packaging related information
Using the debian directory in this commit, it is possible to generate libosmocore and libosmocore-dev packages (dpkgs).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a81850a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+CFLAGS = -Wall -g
+
+%:
+ dh $@
+
+#override_dh_strip:
+# dh_strip --dbg-package=libosmocore-dbg
+