summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther2010-09-30 12:30:41 +0200
committerHolger Hans Peter Freyther2010-09-30 13:00:58 +0200
commit55aea5099c1780700e5acebda712e47b575853e5 (patch)
treec6e2f199d32ccce10bc271174aaf73867439d714 /src/Makefile.am
parentgsm48: Fix gsm48_encode_called - Set no extension bit (diff)
downloadlibosmocore-55aea5099c1780700e5acebda712e47b575853e5.tar.gz
libosmocore-55aea5099c1780700e5acebda712e47b575853e5.tar.xz
libosmocore-55aea5099c1780700e5acebda712e47b575853e5.zip
gsm0480: Add USSD format functions to libosmocore
These routines come from OpenBSC, the msgb_wrap_* functions belong to Mike Haben, the rest is mine. The msgb allocation is compatible to the GSM48 allocation in OpenBSC.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1e97bb9..288a0b9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -13,7 +13,7 @@ libosmocore_la_SOURCES = timer.c select.c signal.c msgb.c rxlev_stat.c \
tlv_parser.c bitvec.c comp128.c gsm_utils.c statistics.c \
write_queue.c utils.c rsl.c gsm48.c gsm48_ie.c \
logging.c gsm0808.c rate_ctr.c gsmtap_util.c \
- gprs_cipher_core.c crc16.c panic.c process.c
+ gprs_cipher_core.c crc16.c panic.c process.c gsm0480.c
if ENABLE_PLUGIN
libosmocore_la_SOURCES += plugin.c