summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther2010-10-11 07:56:06 +0200
committerHolger Hans Peter Freyther2010-10-11 09:25:14 +0200
commitdaa653fc2268ca99389ef2730abf5fe000eb7a37 (patch)
treec50a66012f9f882c0e41fd34567b54cfacb73741 /tests/Makefile.am
parentgsm0480: Move the USSD parsing code to libosmocore (diff)
downloadlibosmocore-daa653fc2268ca99389ef2730abf5fe000eb7a37.tar.gz
libosmocore-daa653fc2268ca99389ef2730abf5fe000eb7a37.tar.xz
libosmocore-daa653fc2268ca99389ef2730abf5fe000eb7a37.zip
ussd: Add a test case, switch parsing to use a gsm48_hdr and len
The current USSD code is not doing any size checks, add a test case to find out how easily we access the data out of bounds. Begin to use the length in some places.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 14c8ca8..0166b4f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,5 +1,5 @@
if ENABLE_TESTS
-SUBDIRS = timer sms
+SUBDIRS = timer sms ussd
if ENABLE_MSGFILE
SUBDIRS += msgfile
endif