summaryrefslogtreecommitdiffstats
path: root/tests/ussd/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther2010-10-11 07:56:06 +0200
committerHolger Hans Peter Freyther2010-10-11 09:25:14 +0200
commitdaa653fc2268ca99389ef2730abf5fe000eb7a37 (patch)
treec50a66012f9f882c0e41fd34567b54cfacb73741 /tests/ussd/Makefile.am
parentgsm0480: Move the USSD parsing code to libosmocore (diff)
downloadlibosmocore-daa653fc2268ca99389ef2730abf5fe000eb7a37.tar.gz
libosmocore-daa653fc2268ca99389ef2730abf5fe000eb7a37.tar.xz
libosmocore-daa653fc2268ca99389ef2730abf5fe000eb7a37.zip
ussd: Add a test case, switch parsing to use a gsm48_hdr and len
The current USSD code is not doing any size checks, add a test case to find out how easily we access the data out of bounds. Begin to use the length in some places.
Diffstat (limited to 'tests/ussd/Makefile.am')
-rw-r--r--tests/ussd/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/ussd/Makefile.am b/tests/ussd/Makefile.am
new file mode 100644
index 0000000..d29506c
--- /dev/null
+++ b/tests/ussd/Makefile.am
@@ -0,0 +1,5 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+noinst_PROGRAMS = ussd_test
+
+ussd_test_SOURCES = ussd_test.c
+ussd_test_LDADD = $(top_builddir)/src/libosmocore.la