summaryrefslogtreecommitdiffstats
path: root/src/host/gsmmap/Makefile.am
diff options
context:
space:
mode:
authorAndreas.Eversberg2010-10-24 16:12:58 +0200
committerAndreas.Eversberg2010-10-24 16:12:58 +0200
commita8ac4bb2dffe2dfe8030ad9f34ec10a4f9684d54 (patch)
treed384bb6d5a3b626f60d26ea452790b0ea7454801 /src/host/gsmmap/Makefile.am
parent[layer23] Adding application to scan/receive and log SYSTEM INFORMATIONS (diff)
downloadosmocom-a8ac4bb2dffe2dfe8030ad9f34ec10a4f9684d54.tar.gz
osmocom-a8ac4bb2dffe2dfe8030ad9f34ec10a4f9684d54.tar.xz
osmocom-a8ac4bb2dffe2dfe8030ad9f34ec10a4f9684d54.zip
Introducing "gsmmap" to convert SYSTEM INFORMATION log into a KML map
Diffstat (limited to 'src/host/gsmmap/Makefile.am')
-rw-r--r--src/host/gsmmap/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/host/gsmmap/Makefile.am b/src/host/gsmmap/Makefile.am
new file mode 100644
index 0000000..d866d02
--- /dev/null
+++ b/src/host/gsmmap/Makefile.am
@@ -0,0 +1,18 @@
+AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
+
+# versioning magic
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS)
+
+sbin_PROGRAMS = gsmmap
+
+INCLUDES += -I../layer23/include -DHOST_BUILD
+gsmmap_SOURCES = gsmmap.c geo.c locate.c log.c ../layer23/src/common/sysinfo.c ../layer23/src/common/networks.c
+gsmmap_LDADD = $(LIBOSMOCORE_LIBS) -lm
+