summaryrefslogtreecommitdiffstats
path: root/Src/osmolib/src/host/osmocon/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Src/osmolib/src/host/osmocon/configure.ac')
-rw-r--r--Src/osmolib/src/host/osmocon/configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/Src/osmolib/src/host/osmocon/configure.ac b/Src/osmolib/src/host/osmocon/configure.ac
new file mode 100644
index 0000000..4130800
--- /dev/null
+++ b/Src/osmolib/src/host/osmocon/configure.ac
@@ -0,0 +1,25 @@
+dnl Process this file with autoconf to produce a configure script
+AC_INIT([osmocon],
+ m4_esyscmd([./git-version-gen .tarball-version]),
+ [baseband-devel@lists.osmocom.org])
+
+AM_INIT_AUTOMAKE([dist-bzip2])
+
+dnl kernel style compile messages
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+dnl checks for programs
+AC_PROG_MAKE_SET
+AC_PROG_CC
+AC_PROG_INSTALL
+
+dnl checks for libraries
+PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore)
+
+dnl checks for header files
+AC_HEADER_STDC
+
+dnl Checks for typedefs, structures and compiler characteristics
+
+AC_OUTPUT(
+ Makefile)