summaryrefslogtreecommitdiffstats
path: root/LogReceiver/CMakeLists.txt
diff options
context:
space:
mode:
authorNiklas2011-09-05 17:04:22 +0200
committerNiklas2011-09-05 17:04:22 +0200
commit5ea57d78c4c42551fcf57d423b13a0897f7db980 (patch)
tree134f4bbfacb52040a75529185f4a959b3d0d23c8 /LogReceiver/CMakeLists.txt
parentadded a new container class which holds config informations about an interfac... (diff)
downloadfbgui-5ea57d78c4c42551fcf57d423b13a0897f7db980.tar.gz
fbgui-5ea57d78c4c42551fcf57d423b13a0897f7db980.tar.xz
fbgui-5ea57d78c4c42551fcf57d423b13a0897f7db980.zip
tried to manage cmake but failed. also tried to add the del_route() method of interface.c but failed too. made a static lib of the customdhcpcd files but couldn't change it to a shared lib. (tried to add SHARE to the add_library code but this resulted in an error multiple declarations of main...
Diffstat (limited to 'LogReceiver/CMakeLists.txt')
-rw-r--r--LogReceiver/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/LogReceiver/CMakeLists.txt b/LogReceiver/CMakeLists.txt
new file mode 100644
index 0000000..fa814b3
--- /dev/null
+++ b/LogReceiver/CMakeLists.txt
@@ -0,0 +1,49 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(LogReceiver)
+
+find_package(Qt4 REQUIRED)
+if (QT4_FOUND)
+ message(STATUS "QT4 found.")
+else(QT4_FOUND)
+ message(FATAL_ERROR "QT4 not found!")
+endif(QT4_FOUND)
+
+#find_package(Qxt REQUIRED)
+
+set(QT_USE_GUI TRUE)
+set(QT_USE_QTNETWORK TRUE)
+set(QT_USE_QTWEBKIT TRUE)
+
+file(GLOB_RECURSE LOGRECEIVER_SOURCES ./*.cpp)
+file(GLOB_RECURSE LOGRECEIVER_MOC_HEADERS ./*.h)
+file(GLOB_RECURSE LOGRECEIVER_UIS ./*.ui)
+#file(GLOB_RECURSE LOGRECEIVER_RCS ./*.qrc)
+
+include_directories(${CMAKE_CURRENT_BINARY_DIR}
+ /usr/include/
+ ../customdhcpcd/src/)
+
+include(${QT_USE_FILE})
+add_definitions(${QT_DEFINITIONS})
+
+link_directories(/usr/lib)
+
+#add_library(
+# /usr/local/Qxt/lib/libQxtCore.so
+# /usr/lib/libqjson.so
+# /usr/lib/libusb-1.0.a
+# )
+
+#QT4_ADD_RESOURCES(FBGUI_RC_SOURCES ${FBGUI_RCS})
+QT4_WRAP_UI(LOGRECEIVER_UI_HEADERS ${LOGRECEIVER_UIS})
+QT4_WRAP_CPP(LOGRECEIVER_MOC_SOURCES ${LOGRECEIVER_MOC_HEADERS})
+
+add_executable(LogReceiver
+ ${LOGRECEIVER_SOURCES}
+ ${LOGRECEIVER_MOC_SOURCES}
+ ${LOGRECEIVER_UI_HEADERS})
+
+target_link_libraries(LogReceiver
+ ${QT_LIBRARIES}
+ sysfs)