summaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
authorSebastian Schmelzer2012-09-10 19:11:21 +0200
committerSebastian Schmelzer2012-09-10 19:11:21 +0200
commitc1ac0992d5c3355bd28a5ae750cb3745b74a959f (patch)
treedd280903cfea1beb345c238488372a95aecc743f /pom.xml
downloadinfoscreen-c1ac0992d5c3355bd28a5ae750cb3745b74a959f.tar.gz
infoscreen-c1ac0992d5c3355bd28a5ae750cb3745b74a959f.tar.xz
infoscreen-c1ac0992d5c3355bd28a5ae750cb3745b74a959f.zip
initia commit
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml128
1 files changed, 128 insertions, 0 deletions
diff --git a/pom.xml b/pom.xml
new file mode 100644
index 0000000..79aa683
--- /dev/null
+++ b/pom.xml
@@ -0,0 +1,128 @@
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <groupId>de.unifr.rz</groupId>
+ <artifactId>infoscreen</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ <packaging>war</packaging>
+
+ <properties>
+ <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
+ <jboss.spec.version>3.0.0.Final</jboss.spec.version>
+ <wicket.cdi.version>6.0-SNAPSHOT</wicket.cdi.version>
+ <wicket.version>6.0.0</wicket.version>
+ <jetty.version>7.5.0.v20110901</jetty.version>
+ </properties>
+
+ <dependencies>
+
+ <dependency>
+ <groupId>org.mnode.ical4j</groupId>
+ <artifactId>ical4j</artifactId>
+ <version>1.0.3</version>
+ </dependency>
+
+ <dependency>
+ <groupId>nu.xss</groupId>
+ <artifactId>xss-wicket</artifactId>
+ <version>0.0.3-SNAPSHOT</version>
+ </dependency>
+
+ <dependency>
+ <groupId>net.ftlines.wicket-fullcalendar</groupId>
+ <artifactId>wicket-fullcalendar-core</artifactId>
+ <version>6.0-SNAPSHOT</version>
+ </dependency>
+
+ <dependency>
+ <groupId>net.ftlines.wicket-cdi</groupId>
+ <artifactId>wicket-cdi</artifactId>
+ <version>${wicket.cdi.version}</version>
+ </dependency>
+
+ <dependency>
+ <groupId>org.apache.wicket</groupId>
+ <artifactId>wicket-core</artifactId>
+ <version>${wicket.version}</version>
+ </dependency>
+
+ <dependency>
+ <groupId>org.jboss.spec.javax.ejb</groupId>
+ <artifactId>jboss-ejb-api_3.1_spec</artifactId>
+ <version>1.0.1.Final</version>
+ </dependency>
+
+ <dependency>
+ <groupId>jboss</groupId>
+ <artifactId>jboss-annotations-ejb3</artifactId>
+ <version>4.2.3.GA</version>
+ </dependency>
+
+ <!-- LOGGING DEPENDENCIES - LOG4J -->
+ <dependency>
+ <groupId>org.slf4j</groupId>
+ <artifactId>slf4j-log4j12</artifactId>
+ <version>1.6.2</version>
+ </dependency>
+
+ <dependency>
+ <groupId>log4j</groupId>
+ <artifactId>log4j</artifactId>
+ <version>1.2.16</version>
+ </dependency>
+
+ <!-- JUNIT DEPENDENCY FOR TESTING -->
+ <dependency>
+ <groupId>junit</groupId>
+ <artifactId>junit</artifactId>
+ <version>4.8.1</version>
+ <scope>test</scope>
+ </dependency>
+
+ <!-- JETTY DEPENDENCIES FOR TESTING -->
+ <dependency>
+ <groupId>org.eclipse.jetty.aggregate</groupId>
+ <artifactId>jetty-all-server</artifactId>
+ <version>${jetty.version}</version>
+ <scope>provided</scope>
+ </dependency>
+
+
+ </dependencies>
+
+ <build>
+ <plugins>
+ <plugin>
+ <groupId>org.apache.maven.plugins</groupId>
+ <artifactId>maven-compiler-plugin</artifactId>
+ <version>2.5</version>
+ <configuration>
+ <source>1.7</source>
+ <target>1.7</target>
+ </configuration>
+ </plugin>
+ <plugin>
+ <groupId>org.jboss.as.plugins</groupId>
+ <artifactId>jboss-as-maven-plugin</artifactId>
+ <version>7.1.1.Final</version>
+ <configuration>
+ <username>${jboss.mgmnt.username}</username>
+ <password>${jboss.mgmnt.password}</password>
+ <!-- Requires setup in ~/.m2/settings.xml .. <profile> <id>jboss-mgmnt-credentials</id>
+ <properties> <jboss.mgmnt.username>..</jboss.mgmnt.username> <jboss.mgmnt.password>..</jboss.mgmnt.password>
+ </properties> </profile> .. <activeProfile>jboss-mgmnt-credentials</activeProfile>
+ .. -->
+ </configuration>
+ <executions>
+ <execution>
+ <phase>install</phase>
+ <goals>
+ <goal>deploy</goal>
+ </goals>
+ </execution>
+ </executions>
+ </plugin>
+ </plugins>
+ </build>
+
+</project> \ No newline at end of file