summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndreas Eversberg2010-05-31 18:45:02 +0200
committerAndreas Eversberg2010-05-31 18:45:02 +0200
commita12d7eee22a72f4c999535892763dde15212e89e (patch)
tree32e20ad128c8bba3c80441ca771da8aa0c4fd5f2 /Makefile.am
parentFixed LCR to work with the current API of OpenBSC. (diff)
downloadlcr-a12d7eee22a72f4c999535892763dde15212e89e.tar.gz
lcr-a12d7eee22a72f4c999535892763dde15212e89e.tar.xz
lcr-a12d7eee22a72f4c999535892763dde15212e89e.zip
Splitted GSM support into BS (network) and MS (mobile) part.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 28 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index aaa23f6..f25280d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,19 +43,43 @@ INSTALLATION_DEFINES = \
-DLOG_DIR="\"$(LOGdir)\"" \
-DEXTENSION_DATA="\"$(EXTENSIONdir)\""
-if ENABLE_GSM
+GSM_INCLUDE =
+GSM_SOURCE =
+GSM_LIB =
-GSM_INCLUDE = -DWITH_GSM -I./openbsc/include -I./libosmocore/include -I./openbsc
+if ENABLE_GSM
-GSM_SOURCE = gsm_audio.c gsm.cpp gsm_conf.c openbsc/src/bsc_init.c openbsc/src/bsc_vty.c openbsc/src/vty_interface_layer3.c openbsc/src/bsc_api.c openbsc/src/bsc_version.c
+GSM_INCLUDE +=
-GSM_LIB = /usr/lib/libgsm.a ./openbsc/src/libbsc.a ./openbsc/src/libmsc.a ./openbsc/src/libvty.a -losmovty -losmocore -ldbi -lcrypt
+GSM_SOURCE += gsm_audio.c gsm.cpp gsm_conf.c
+
+GSM_LIB += /usr/lib/libgsm.a
#gsm_audio.po: gsm_audio.c gsm_audio.h
# $(CC) -D_GNU_SOURCE -fPIC -c gsm_audio.c -o gsm_audio.po
endif
+if ENABLE_GSM_BS
+
+GSM_INCLUDE += -DWITH_GSM_BS -I./openbsc/include -I./libosmocore/include -I./openbsc
+
+GSM_SOURCE += gsm_bs.cpp openbsc/src/bsc_init.c openbsc/src/bsc_vty.c openbsc/src/vty_interface_layer3.c openbsc/src/bsc_api.c openbsc/src/bsc_version.c
+
+GSM_LIB += ./openbsc/src/libbsc.a ./openbsc/src/libmsc.a ./openbsc/src/libvty.a -losmovty -losmocore -ldbi -lcrypt
+
+endif
+
+if ENABLE_GSM_MS
+
+GSM_INCLUDE += -DWITH_GSM_MS -I./layer23/include -I./libosmocore/include
+
+GSM_SOURCE += gsm_ms.cpp layer23/src/app_mobile.c
+
+GSM_LIB += ./layer23/src/liblayer23.a ./layer23/src/libvty.a ./libosmocore/build-host/src/.libs/libosmocore.a
+
+endif
+
if ENABLE_SS5
SS5_INCLUDE = -DWITH_SS5