summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndreas Eversberg2008-11-04 09:31:09 +0100
committerAndreas Eversberg2008-11-04 09:31:09 +0100
commitefc550418c0b107c07818809a3d8e779e476dcd4 (patch)
tree4ce7e1612b611a95007fa335019a1ebc19fa993f /Makefile.am
parentMerge branch 'master' of ssh://jolly@www.mISDN.org/var/git/lcr (diff)
downloadlcr-efc550418c0b107c07818809a3d8e779e476dcd4.tar.gz
lcr-efc550418c0b107c07818809a3d8e779e476dcd4.tar.xz
lcr-efc550418c0b107c07818809a3d8e779e476dcd4.zip
Added processing of second caller id.
New routing macht rule to filter second caller id. Fixed extensions directory path. "make clean" now cleans ".po" files. Fixed unititialized variable bugs and compiler warnings. modified: Makefile.am modified: Makefile.in modified: action.cpp modified: apppbx.cpp modified: callerid.c modified: chan_lcr.c modified: dss1.cpp modified: dss1.h modified: extension.c modified: gentones.c modified: ie.cpp modified: mISDN.cpp modified: message.h modified: port.cpp modified: route.c modified: route.h modified: socket_server.c modified: tones.c modified: trace.c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 844c2d8..7f1b577 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,7 +41,7 @@ INSTALLATION_DEFINES = \
-DCONFIG_DATA="\"$(CONFIGdir)\"" \
-DSHARE_DATA="\"$(SHAREdir)\"" \
-DLOG_DIR="\"$(LOGdir)\"" \
- -DEXTENSION_DATA="\"$(EXTENSIONdir)/extensions\""
+ -DEXTENSION_DATA="\"$(EXTENSIONdir)\""
INCLUDES = $(all_includes) -I/usr/include/mISDNuser $(INSTALLATION_DEFINES)
@@ -134,6 +134,9 @@ install-data-hook:
echo "NOTE: special efi tones already exists, not overwritten." ; else \
cp -a tones_efi $(SHAREdir) ; fi
+clean-generic:
+ rm -f *.po
+
# test rule, nothing important
#echo:
# -echo $(all_libraries) >&2