summaryrefslogtreecommitdiffstats
path: root/LogReceiver/CMakeLists.txt
diff options
context:
space:
mode:
authorNiklas2011-09-19 16:38:13 +0200
committerNiklas2011-09-19 16:38:13 +0200
commitcf7bfd8d92c43daa81de1ede78e117686902e93f (patch)
tree051f2fdfa86a50522207c342376892a65eb7c8d0 /LogReceiver/CMakeLists.txt
parentremove another build dir (diff)
downloadfbgui-cf7bfd8d92c43daa81de1ede78e117686902e93f.tar.gz
fbgui-cf7bfd8d92c43daa81de1ede78e117686902e93f.tar.xz
fbgui-cf7bfd8d92c43daa81de1ede78e117686902e93f.zip
added a new version of the routemanager. now the delRoute and addRoute is working with libnl functions.but still there is an error: /usr/include/netlink/route/route.h:60:57: error: ‘realm_t’ has not been declared /usr/include/netlink/route/route.h:61:8: error: ‘realm_t’ does not name a type
Diffstat (limited to 'LogReceiver/CMakeLists.txt')
-rw-r--r--LogReceiver/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/LogReceiver/CMakeLists.txt b/LogReceiver/CMakeLists.txt
index 1cd1686..690ecf4 100644
--- a/LogReceiver/CMakeLists.txt
+++ b/LogReceiver/CMakeLists.txt
@@ -24,6 +24,8 @@ file(GLOB LOGRECEIVER_RCS ./*.qrc)
include_directories(${CMAKE_CURRENT_BINARY_DIR}
/usr/include/
+ /usr/include/netlink/
+ /usr/include/netlink/route/
./../customdhcpcd/src/
./build
${QT_INCLUDES}
@@ -54,4 +56,4 @@ add_executable(LogReceiver
target_link_libraries(LogReceiver
${QT_LIBRARIES}
- sysfs customdhcpcd)
+ sysfs customdhcpcd nl)